Excel es un programa creado por Microsoft que representa una hoja de cálculo que sirve para crear tablas dinámicas, cálculos matemáticos, y hasta pequeños programas (desarrollo de instrucciones estilo software).

Una de las funciones más usadas en Excel es Si, que en desarrollo de software se traduce a “if”. Esta es una instrucción lógica que denota una condición. Se emplea para establecer lo que se debe hacer si se cumple el requisito escrito después del “Si”.

Para entender de qué se trata la función si o if miremos este ejemplo cotidiano: Si hoy llueve, entonces no iremos al cine. En algunos casos existe una acción a realizar si no se cumple la condición, es decir: sino (hoy no llueve), iremos al cine.

En Excel se aplica el Si para comparar elementos numéricos y realizar alguna acción: Si A, entonces B, sino C. La sintaxis en la hoja de cálculo es similar a:

=SI(algo es verdadero, hacer algo; si es falso, hacer algo diferente).

Las comparaciones se pueden hacer utilizando:

  • Igual (=)
  • Desigual (<>)
  • Menor a (<)
  • Mayor a (>)
  • Menor o igual a (<=)
  • Mayor o igual a (>=)

Ejemplos de función SI en Excel

  1. =SI(A1>=100;”Objetivo alcanzado”;”Objetivo no alcanzado”).
  2. =SI(D2<10;”SI”;”NO”).
  3. =SI(B9=”-“; “Repetido”;”No repetido”)
  4. =SIDIAS(HOY();F2>30;C2*0,75;C2)
  5. =SI(Y(DIAS(HOY();F11)>30;E11<10);C11*0,5;SI(DIAS(HOY();F11);C11*0,75;C11))
  6. =CONTAR.SI(C2:C111;”Pagado”)
  7. =SI.CONJUNTO(Y(DIAS(HOY();F2)>30;E2<10);C2*0,5;SI(DIAS(HOY();F2);C2*0,75;C2))
  8. =SI(B2>=60,”APROBADO”,”REPROBADO”)
  9. =SI(ESNUMERO(A2), “SI”, “NO”)
  10. =SI(ESNUMERO(A2), SUMA(A2, $D$1), “NO”)
  11. =SI(A6>A7;VERDADERO;FALSO)
  12. =SI(A6>A7;”Es mayor”;”No es mayor”)
  13. =SI(A13 > A14; A13 + A14 ; FALSO)